View Issue Details

IDProjectCategoryView StatusLast Update
0027164mantisbtotherpublic2020-09-17 16:40
ReporterMythotical Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSCentOSOS Version7
Product Version2.24.2 
Summary0027164: Error #200 When Selecting Profile
Description

I added a profile to my account when I select it from the dropdown and click Submit, I get this error.

Steps To Reproduce
  1. Go to My Account
  2. Click Profiles
  3. Add a profile (if one doesn't exist)
  4. Scroll to the bottom
  5. Select a profile (or newly created profile) from the dropdown
  6. Click Submit and error appears
TagsNo tags attached.

Relationships

related to 0027256 resolveddregad Refactor Profiles management pages to display a list of records 

Activities

Mythotical

Mythotical

2020-08-26 19:26

reporter  

Issue-Tracker.png (160,765 bytes)   
Issue-Tracker.png (160,765 bytes)   
Profiles-Issue-Tracker.png (137,373 bytes)   
Profiles-Issue-Tracker.png (137,373 bytes)   
dregad

dregad

2020-08-27 03:35

developer   ~0064294

Looks like you simply forgot to select which action (Edit, Make Default, Delete) you would like to take on the selected profile.

Mythotical

Mythotical

2020-08-27 04:53

reporter   ~0064295

Oooooh, gotcha. That is a little confusing if you ask me, maybe change that up in a future version so it's not so confusing.

dregad

dregad

2020-08-27 11:09

developer   ~0064296

TBH even though I don't use it myself, I don't like this screen's UX... I think its logic is backwards, i.e. selecting an action from a radio, then the object before clicking Submit. It would make more sense to present a list of profiles with individual action buttons, like we do in other parts of MantisBT (e.g. adm_config_report.php).

Do you have other suggestions of what we should do to make things less confusing ?

Mythotical

Mythotical

2020-08-28 18:47

reporter   ~0064317

I have one more, on the Manage Configuration -> Manage Columns, have the properties in a checkbox list format that is scrollable that way everyone knows what fields are available to include.

Oh one more, Manage Configuration -> Manage Site would be a good idea to have where we can manage our logo, site title, etc without having to use config_inc.php variables to set different things. I don't mean include everything, just the normal stuff of site logo, site name, site title, site description, keywords, language, theme.

Also have it possible where people can upload to a new folder called 'themes' where you create a folder of your choosing, upload a CSS file and preview file then on the config for the site they choose from a list of names of styles in that folder which the names would have to be kept in a PHP or XML file. A theme manager would be nice on top of this allowing us to see what each theme looks like but if people provide a screenshot with their download we wouldn't need a theme manager.

That is all I have for suggestions for now. If I find time, I'll do a pull request and try to do some of this myself to help ya guys out.

dregad

dregad

2020-08-29 07:16

developer   ~0064324

I meant, specifically for the profile selection feature ;-)

Please open separate issues (look for existing ones first) to track your suggestions. And pull requests would be great !

I have one more, on the Manage Configuration -> Manage Columns, have the properties in a checkbox list format that is scrollable that way everyone knows what fields are available to include.

This plugin https://github.com/mantisbt-plugins/InlineColumnConfiguration might be what you're looking for

Mythotical

Mythotical

2020-08-30 17:40

reporter   ~0064330

LOL my bad, misunderstood what you meant. I'll do that before I create new feature suggestions. Yeah that plugin will do the trick.

dregad

dregad

2020-09-06 11:33

developer   ~0064376

Last edited: 2020-09-07 01:34

View 2 revisions

@Mythotical please see 0027256 as a follow-up to improve the Manage Profile screens' user interface.

Issue History

Date Modified Username Field Change
2020-08-26 19:26 Mythotical New Issue
2020-08-26 19:26 Mythotical File Added: Issue-Tracker.png
2020-08-26 19:26 Mythotical File Added: Profiles-Issue-Tracker.png
2020-08-27 03:35 dregad Assigned To => dregad
2020-08-27 03:35 dregad Status new => resolved
2020-08-27 03:35 dregad Resolution open => no change required
2020-08-27 03:35 dregad Note Added: 0064294
2020-08-27 04:53 Mythotical Note Added: 0064295
2020-08-27 11:09 dregad Note Added: 0064296
2020-08-28 18:47 Mythotical Note Added: 0064317
2020-08-29 07:16 dregad Note Added: 0064324
2020-08-30 17:40 Mythotical Note Added: 0064330
2020-09-06 11:32 dregad Relationship added related to 0027256
2020-09-06 11:33 dregad Note Added: 0064376
2020-09-07 01:34 dregad Note Edited: 0064376 View Revisions
2020-09-17 16:40 atrol Status resolved => closed