View Issue Details

IDProjectCategoryView StatusLast Update
0027267mantisbtadministrationpublic2020-09-28 16:43
ReporterMythotical Assigned Toatrol  
PrioritynormalSeveritymajorReproducibilityN/A
Status closedResolutionduplicate 
PlatformLinuxOSCentOSOS Version7
Product Version2.24.2 
Summary0027267: Themes folder possibility
Description

Have it possible where people can upload to a new folder called 'themes' where you create a folder of your choosing, upload a CSS file and preview file then on the config for the site they choose from a list of names of styles in that folder which the names would have to be kept in a PHP or XML file. A theme manager would be nice on top of this allowing us to see what each theme looks like but if people provide a screenshot with their download we wouldn't need a theme manager.

Steps To Reproduce

NONE

Additional Information

They this would work is like so:

  1. Under root have "themes" directory
  2. Inside "themes" create a new directory say "darkblue"
  3. Upload the CSS file related or created to the theme "darkblue"
  4. This would be related to my previous report for Manage Configuration -> Manage Site where a Theme selection would read from these folders allowing an admin to choose the theme.
TagsNo tags attached.

Relationships

duplicate of 0023771 new Allow for theme other than default "ace" 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-09-09 14:58 Mythotical New Issue
2020-09-09 15:09 atrol Assigned To => atrol
2020-09-09 15:09 atrol Status new => resolved
2020-09-09 15:09 atrol Resolution open => duplicate
2020-09-09 15:09 atrol Relationship added duplicate of 0023771
2020-09-28 16:43 atrol Status resolved => closed