View Issue Details

IDProjectCategoryView StatusLast Update
0027992mantisbtdocumentationpublic2021-03-07 18:28
Reporterbradbulger Assigned Todregad  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Target Version2.25.0Fixed in Version2.25.0 
Summary0027992: Remove helper_alternate_class() calls from Developers Guide and document alternative
Description

I went to a plugin page and got a bunch of errors, "Deprecated functionality: "helper_alternate_class", use "CSS" instead."

I do not know what that means. I have a kind of vague idea from a lot of searching, but there are no specific examples. 0016471 says "This is not needed with modern CSS styled layouts." which is nice to know I guess? But not very specific about the hows and whys.

The Developers Guide example plugin code still calls that helper_alternate_class() function. It would be nice to update that with an example of what a "modern CSS styled layout" is when it's at home.

TagsNo tags attached.

Relationships

related to 0016471 closedgrangeway Use CSS to set alternating colors in HTML tables 
related to 0027993 closeddregad Host the Example Plugin from the Developers Guide in a repository in mantisbt-plugins organization 

Activities

dregad

dregad

2021-02-25 08:30

developer   ~0065154

Thanks for the heads up. Indeed the Developers' Guide should have been updated, sorry about that.

I do not know what that means. I have a kind of vague idea from a lot of searching, but there are no specific examples

What this means, is that the helper_alternate_class() function will be removed in a future version of Mantis; the deprecation message is there to inform administrators and plugin developers that they need to do something about this before it becomes an actual error.

Until the documentation has been revised, you can have a look at one of the bundled plug-ins for reference (e.g. MantisCoreFormatting) and more specifically how it was updated to remove the helper_alternate_class() function, as well as changesets attached to 0016471.

dregad

dregad

2021-02-25 08:46

developer   ~0065155

This is how the Developers' Guide example plugin looks like in MantisBT 2.24.4

example_plugin_config_page.png (42,882 bytes)   
example_plugin_config_page.png (42,882 bytes)   
dregad

dregad

2021-02-26 19:11

developer   ~0065157

I have revised the Example Plugin, which is now available as a standalone repo: https://github.com/mantisbt-plugins/Example

The attached screenshot shows how it looks like now.

Related Changesets

MantisBT: master 3868bdb9

2021-02-26 19:00:07

dregad

Details Diff
Doc: improve Dev Guide Plugins section

- General revision and various improvements to the "Building a Plugin"
section
- Remove references to deprecated helper_alternate_class() function
- remove the "Example Plugin Source Listing" section, code is now hosted
in a GitHub repository in the mantisbt-plugins organization [1]
- Improve the Example Plugin; for details, see [1]

Fixes 0027992, 0027993

[1]: https://github.com/mantisbt-plugins/Example
Affected Issues
0027992, 0027993
mod - docbook/Developers_Guide/en-US/Plugins.xml Diff File
mod - docbook/Developers_Guide/en-US/Plugins_Building.xml Diff File
rm - docbook/Developers_Guide/en-US/Plugins_Building_Source.xml Diff File